
 

 

出國報告（出國類別：考察） 

 

 

 

 

 

 

 

參加 RAPS 使用者研討會 
 

 

 

 

 

 

 

服務機關：行政院飛航安全委員會 

姓名職務：副飛安官／官文霖 

派赴國家：加拿大渥太華 

出國期間：2005 年 6月 26 日至 7月 3日 

報告日期：2005 年 7月 5日 



 

ASC-TRM-05-07-001 1

公務出國報告提要 系統識別號 C09402637 

出國報告名稱：參加 RAPS 使用者研討會 

頁數：42 頁  含附件：是 

 

出國計畫主辦機關：行政院飛航安全委員會 

聯絡人：黃佩蒂 

電 話：(02) 2547-5200 

 

出國人員姓名：官文霖 

服務機關：行政院飛航安全委員會 

單位：調查實驗室 

職稱：副飛航安全官 

電話：(02) 2547-5200 

 

出國類別：■1考察□2進修□3研究□4實習□5其他 

 

出國期間：民國 94 年 6 月 26 日至 7月 3日 

出國地區：加拿大渥太華市 

 

報告日期：民國 94 年 7 月 5 日 

分類號/目 

 

關鍵詞：加拿大運輸安全委員會、飛航資料紀錄器解讀、飛航紀錄器。 

 

內容摘要：  

加拿大運輸安全委員會（TSB）於 1985 年開始研發飛航資料紀錄器解讀、

分析與動畫系統（RAPS），2001 年 8 月以後，TSB 將 RAPS 產權技術轉移給

FlightScape 公司，以改善服務效率與研發更完善之系統。該解讀系統直至 2005

年共有 21 個政府機關，4 家飛機製造廠，加拿大航管單位，2 家私人公司，與

15 家航空公司加入會員。 

目前，歐美等國之調查機關，我國及中國大陸，多數飛機製造商均使用相

同的解讀系統（RAPS/Insight），它將有助於提升飛航事故調查之效率。基於持

續擴展本會之飛航紀錄器解讀與分析能力，應逐年推薦本會年輕飛航紀錄器工程

師參加飛航紀錄器解讀及分析訓練。並添購一套解讀系統（Insight）以分散工

作負擔。我國調查實驗室已列全球五大實驗室（美加法澳），本會應致力於推動

亞太地區飛航事故調查及飛安研發之合作及分享。 

 

本文電子檔已上傳至出國報告資訊網。 
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出國報告審核表 

出國報告名稱：參加 RAPS 使用者研討會 

出國人姓名 職稱 服務單位 

官文霖 副飛航安全官 行政院飛航安全委員會 

出國期間：94 年 6 月 26 日至 7月 3日 報告繳交日期：94 年 7 月 6 日 

出

國

計

畫

主

辦

機

關

審

核

意

見 

□1.依限繳交出國報告 

□2.格式完整（本文必須具備「目的」、「過程」、「心得」、「建議事項」） 

□3.內容充實完備 

□4.建議具參考價值 

□5.送本機關參考或研辦 

□6.送上級機關參考 

□7.退回補正，原因：□ 不符原核定出國計畫□ 以外文撰寫或僅以所蒐集

外文資料為內容□ 內容空洞簡略□ 電子檔未依格式辦理□ 未於資訊

網登錄提要資料及傳送出國報告電子檔 

□8.本報告除上傳至出國報告資訊網外，將採行之公開發表： 

□辦理本機關出國報告座談會（說明會），與同仁進行知識分享 

□於本機關業務會報提出報告 

□9.其他處理意見及方式： 

層

轉

機

關

審

核

意

見 

□1.同意主辦機關審核意見 □全部 □部份________（填寫審核意見編號） 

□2.退回補正，原因：____________ 

□3.其他處理意見： 

 

說明： 

一、出國計畫主辦機關即層轉機關時，不需填寫「層轉機關審核意見」。 

二、各機關可依需要自行增列審核項目內容，出國報告審核完畢本表請自行保存。 

三、審核作業應儘速完成，以不影響出國人員上傳出國報告至「公務出國報告資訊網」為原則。 
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一、目的與行程安排 

由於科技日新月異，飛航紀錄器正處於新舊時代交替過程，各國的飛航事

故調查機關的紀錄器專家都曾遭遇不同之問題，且擁有獨特的解決經驗。 

本會每年例行參加 RAPS 使用者會議，此會議主要為集合全世界飛航紀錄器

調查人員，飛機製造商，以及航空公司飛航資料監控（FDM）部門人員，共同討

論飛航紀錄器解讀經驗及技術交流。本會派員參加RAPS使用者會議，為收集RAPS

新版本資料，與各國飛航紀錄器解讀專家交流。今年（94）RAPS 使用者會議於

加拿大渥太華市舉行。 

 

日期 行程安排 搭程飛機班次 時 間 

06/26 台北–溫哥華 長榮航空 10 23:525 ~ 19:40 

06/27 溫哥華–渥太華 楓葉航空 166 09:20 ~ 16:55 

06/28 

~ 

06/30 

RAPS 使用者研討會 

07/01 渥太華–溫哥華 楓葉航空 139 18:55 ~ 21:10 

07/02 

~ 

07/03 

溫哥華–台北 長榮航空 9 02:25 ~ 05:10 
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二、過程 
會議地點：加拿大  渥太華市 

主辦單位：Flightscape 公司（原加拿大運安會工程部） 

協辦單位：加拿大技術研發中心(TDC)，加拿大運安會(TSB)，國際運協(IATA)，

Avionica 公司，DRS 公司。 

RAPS 使用者研討會議程 

 

Thesday June 28 

(1)8:50 – 9:00 Introduction 簡介 Mike Poole, Flightscape 

 

(2) 9:00 – 9:10 Opening Remarks 

Terry Burtch, Director General Investigations Operations, TSB/Canada 

 

(3)9:10-9:20 IATA Teaming Agreement IATA合作 David Mawdsley, Director 

of Safety, IATA 

 

(4)9:20-9:35 Radar Analysis (RADS) Update 雷達資料分析Larry Lachance, 

Director, Safety Evaluations and Investigations, NAV CANADA 

 

(5)9:35-10:20 Product Development Update 產品研發更新 Rob Runolfson, 

Flightscape 

 

(6) 10:20-10:40 Coffee Break 
 

(7)10:40-11:00 Next Generation Parameter Databases 下一代飛航參數資料

庫之發展 Rob Runolfson, Flightscape   

 

(8)11:00-11:25 New Concept for Handling Flight Data atBoeing 波音之

飛航資料處理新觀念 Brian Predmore, Boeing 

 

(9)11:25-11:50 Airbus Integration Test Center 空客之整合中心 Yves 

Lebiannic, Airbus  

 

11:50-13:15     Lunch 

 

Moderator, Ted Givins,  

Chief, Flight Recorders & Perfornance, SB/Canada 
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(10) 13:15-13:40 Runway Incursion/Analysis & Animation 
Dennis Grossi, NTSB 跑道入侵之分析與動畫 

 

(11) 13:40-14:10 B737-700 Unstable Approach 不穩定進場 

Graham Liddy, Air Accident Investigation Board, Ireland 

 

(12) 14:10-14:30 New FDR Capabilities FDR 新功能 

Wim Furster, The Dutch Safety Board 

 

(13) 14:30-14:50 New FDR Capabilities  
Kevin, Kuessales, Army Aviation Centre, Australian Defense Force 

 

(14) 14:50-15:10 Update from Down Under 澳洲飛航資料解讀及分析現狀 

Michael Hill, ATSB/Australia 

 

(15) 15:30-15:50 Flight Data Update ALPA飛航資料解讀及分析現狀 

Corey Stephens, ALPA US 

 

(16) 15:50-16:10 Mishap and Animation Facility - Before and After 美國

空軍之飛航事故動畫裝備 

Jeff Barnette, USAF 

 

(17) 16:10-16:30 Transition to Insight 美國海軍之航資料解讀及分析換裝 

Chip Brown, US Naval Safety Center 

 

(18) 16:30-16:50 CFIT Incidents 可控飛行撞地之事故 

Major Jim Burger, DFS/Canada 

 

19:00 Dinner Hosted by Flightscape 

Wednesday June 29 

(19) 9:00-9:15 Business Development Overview  Mike Poole, Flightscape  

 

Moderator: Howard Posluns, Chief, Advanced Technology, Transportation 

Development Centre 

 

(20) 9:20-9:40 Safety Data Management & Analysis, 飛航安全資料管理及分

析 David Mawdsley, Director of Safety, IATA 
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(21) 9:40-10:00 TDC Data Sharing R&D Study Tom Dunn, Transport Canada & 
Wayne Jackson, Flightsape 

 

(22) 10:20-10:40 Data Research/Simulator Training 資料研究及模擬訓練 

Martyn Roast, Oxford Aviation  

 

(23) 10:40-11:10 IATA’s FDA Service  IATA飛航資料解讀服務 Jill 

Sladen-Pilon, IATA and Dion Bozec, Flightscape 

 

(24) 11:10-11:35 FDA Program Status  Zoom航空之飛航資料解讀及分析現狀 

Captain Vic Charlebois, Zoom Airlines 

 

11:35-13:00 Lunch 

 

(25) 13:00-13:25 Cathay Pacific Safety 國泰航空之飛航資料解讀及分析現

狀 Developments, Trevor Ng, Cathay Pacific 

 

(26) 13:25-13:50 FDA Program Status Captain Nduati Njama, Kenya Airways 
 

(27) 13:50-14:25 A310 Pitch Up Event A310異常上仰事件 Captain Mike 

Dillolo, Air Transat 

 

14:25-14:45 Coffee 

 

(28) 14:45-15:05 FDA Program Update 西南航空之飛航資料解讀及分析現狀 

Don Carter, Southwest Airlines 

 

(29) 15:05-15:20 Wireless Download Technology 無線飛航資料下載技術  

Gilles Landry, Avionica 

 

(30) 15:20-15:30 Aircraft Performance Monitoring Study 航機性能分析 

 

---------------------------------------------------------------------- 

Thursday June 30 

---------------------------------------------------------------------- 

(31) 9:00-11:00 Tour of Transportation Safety Board of Canada 

Laboratories. 參觀加拿大運輸安全委員會工程部實驗室 
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三、心得 

3.1 RAPS 使用者研討會 

加拿大運輸安全委員會（TSB）於 1985 年著手研發飛航資料紀錄器解讀、

分析與動畫系統（Recovery，Analysis and Presentation System，簡稱 RAPS）。

2001 年八月以後，TSB 將 RAPS 產權技術轉移給 FlightScape 公司，目的為改善

服務效率與研發更完善之系統。該研討會也由 RAPS Users Conference 改為

Flightscape Users Conference。 

RAPS 原屬於各政府航機失事機關所用，直至 2005 年共有 21 個政府機關，4

家飛機製造廠（波音，空中巴士，Bombardier，Saab），加拿大航管單位

（NavCanada），2 家私人公司（英國 Cranfield 大學，UAG Aerospace），與 15

家航空公司（Air Moldova，Air New Zealand，Air Transat，Carpatair，Cathay 

Pacific，El Al，Evergreen International Airlines，First Air，Harmony 

Airways ， IATA ， Northwest Airlines ， Southwest ， US Airline Pilots 

Association，WestJet，Zoom Airlines）加入會員。 

本次 Flightscape 使用者研討會約有 130 餘人參加，共有 30 篇論文，以下

說明出席機關或單位表達之意見。 

國際航空運輸協會(IATA)，今年與 Flightscape 公司策略聯盟，將於 2005

年 10 月對 IATA 會員提供飛航資料解讀分析服務（Flight Data Analysis，FDA），

詳附錄一。 

荷蘭運安會（DSB）屬於 Multi-Model 運輸安全委員會，全會人員約 30 人，

航空調查人員 7人。荷蘭運安會職掌該國航空，鐵路，公路，船隻及管線等運輸

安全調查。未來，將擴大職權含概建築物之公共安全調查。目前，荷蘭運安會只

有 Insight Analysis 模組。 

澳洲運安會（ATSB）屬於 Multi-Model 運輸安全委員會，載具紀錄器實驗

室有 4人，3人負責飛航紀錄器，1人（Michael Hill）負責火車及輪船紀錄器。 

長久以來，加拿大運安會（TSB）於飛航紀錄器之解讀技術研發極為出色，

但是缺乏飛航性能專業人員。過去，他們仰賴加拿大國科會（NRC）；當下，他們

多仰賴於 Flightscape 公司的技術委託服務。 

TSB 工程部新上任的 TED GIVINS 主管極力整頓工程部之紀錄器及載具性能

小組，目前共有 6人，1人為負責火車紀錄器，另 1人負責飛航性能，其餘 4人

專業為飛航紀錄器。TSB 執行長 Terry Burth 於會中開場致詞指出：「因應未來 5

年改善飛航安全之目標，TSB 今年開始執行兩大計劃－未來飛航紀錄器編碼及解

讀；飛航性能研發桌上型 6DOF 飛航模擬器。」 

Insight 軟體模組現況 

Insight/Animation，Insight/Analysis 及 Insight/Recovery 3 項 PC 版軟

體，相當於 RAPS UNIX 版本的飛航動畫，飛航資料分析及磁帶式飛航資料採集模
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組。它的 License 採用 3組不同的機碼，須向 FlightScape 申請，新版的 Insight 

軟體模組的更新功能說明詳附錄二。 

Insight/FDM 是新的模組，將於 2005 年 10 月推出。主要用於航空公司飛航

資料例常性解讀，事件偵測，及統計等功能。以.NET 為基礎，使用者有許多客

製化功能。Insight/FDM 也是 IATA 提供給會員作飛航資料解讀之平台。 

 

Insight/Animation flight animation system 

Insight/Analysis Fully data analysis  

Insight/FDM Event Detection, Trending and Reporting 

Insight/Recovery ARINC data tape decoding and bit recovery 

Insight/Sim 6 DOF aerodynamic modeling  

Insight/ProView Interactive animation viewer (laptop) 

Insight/View Freely distributed viewers 

Insight/View with ADG Proview with flight path generation 

 

目前，政府使用者最關心的議題是 Insight License 控管，及 RAPS 不再有

升級版兩大問題。澳洲 ATSB 使用 License Sever 去啟動 Insight Analysis，

Insight Animation，Insight Recovery。ATSB 有 4 組 Insight License，但有

多於四台電腦裝 Insight。美國 NTSB 有 4 組 Insight Analysis 及 Insight 

Animation 的 License，並繼續使用 RAPS 工作站。法國 BEA 有 4 組 Insight 

Analysis 的 License，有 2 組 Insight Animation 的 License。加拿大有 4 組

Insight License，中國 CAAC 有 2 組 Insight License。相形之下，本會實驗室

至少有三名人員從事飛航資料解讀及分析工作，但只有 1組 Insight License，

實有增購必要，並藉以陪養人才，分散工作負擔。 

往年，研討會中 Flgihtscape 的技術人員都會介紹及教導新版的軟體功能，

今年則沒有這類活動。因為，Flgihtscape 公司對新版軟體的功能教導，將採取

收費訓練方式。地點可在 Flgihtscape 公司的訓練課程中，或使用者軟體安裝地

點。圖 1為 Insight Animation 飛航動畫成果展示；圖 2 為 Insight Analysis 

參數表列功能，以滑鼠按住參數檔頭可作交換位置；圖 3 雷達資料動畫處理系

統(Radar Data De-briefing System, RADS) 

Aircraft Configurations including: 

 FFD file development/validation 

 CSV data import 

 Data Import Automation 

 Animation template 

 Instrument models 

 ADG configuration (automates data processing, flight path creation, 

derived parameter) 
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 Airport and terrain models 

 

圖 1 Insight Animation 飛航動畫成果展示[ PC 1.5 版 ]
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圖 2 Insight Analysis 參數表列功能 

圖 3 雷達資料動畫處理系統(Radar Data De-briefing System, RADS)



 

ASC-TRM-05-07-001 12

3. 2 下一代飛航參數資料庫之發展 

論文發表者：Rob Runolfson, Flightscape 

 

今年 2 月美加地區的飛航紀錄器調查員與飛機製造商於加拿大渥太華召開

下一代飛航參數資料庫會議，與會單位包括：波音，空中巴士，Bombardier，Saab，

BEA，NTSB，TSB。該會議的主旨在強化 Insight 使其能解讀所有的 ARINC 格式之

飛航資料，發展ＡPI 程式使各式飛航參數資料庫能匯入 Insight 的 FFD 中，會

中也提到 ARINC 新規範的飛航參數資料庫之標準化格式－FREDS（Flight 

Recorder Electronic Documentation Standard）。目前，Insight 能處理的飛

航參數資料庫只有 FREDS，Boeing CSV，Airbus Calibration；會中統計出 Insight

近期要發展的飛航參數資料庫匯入ＡPI 程式共有 16 種。 

以空中巴士的飛機為例，A300-600 約紀錄 250 項參數，A320 約紀錄 250 項

參數，A340 約紀錄 700 項參數，A330-200 約紀錄 900 項參數，A340-600 約紀錄

1400 項參數，A380 約紀錄 2500 項參數。 

 

3. 3 空中巴士對 Inisght 軟體之整合應用 

論文發表者：Yves Le Biannic, Airbus Flight Test Center 

 

空中巴士對 Inisght 軟體之整合應用論文中提出，以發展 A340 為例，飛行

測試中心對飛航資料之應用分四階段，說明如下（詳圖 4）： 

(1) AIDS/FDRS Integration Test，（出廠前有 10版本 150 項整合測試項目） 

(2) AIDS programming，（出廠前有 60 組程式 600 項測試項目；出廠後有 20 組

程式 200 項測試項目） 

(3) FDR Verification，（出廠前有 187 種 FDR 規格 1100 項 FDR 參數確認項目；

出廠後有 110 種 FDR 規格 160 項 FDR 參數確認項目） 

(4) Event analysis，（出廠前有 120 種事件偵測 125 項事件分析分類法；出廠

後有 410 種事件偵測 600 項事件分析分類法） 

Biannic 也提出空中巴士對飛航業者要求的工作，如何整合飛測中心及設計

部門之專長，根據飛航業者提供的飛航資料進行研究分析，並找出解決之道，詳

圖 5。因為，空中巴士 2004 才開始使用 Insight Analysis，Insight Animtion，

主要的目的為與飛航事故調查單位使用相同的飛航紀錄器解讀及分析系統，以避

免調查過程中出現同一飛航資料紀錄器，若因飛機製造商使用不同的解讀裝備，

造成解讀資料之差異與紛爭。 

 



 

ASC-TRM-05-07-001 13

150
200

600

1100

160

600

125

120 events

410 events

110 A/C

187 A/C

20 programming

60 programming
10 versions

AIDS/FDRS
Integration test

AIDS
programming

FDR 
verification

Event
Analysis

AIDS = aircraft integrated data system
FDRS= flight data recording system

In
 se

rv
ic

e
B

ef
or

e 
 d

el
iv

er
y

Case A340 FTI

 

圖 4 空中巴士飛行測試中心對飛航資料之應用階段 

 

圖 5 空中巴士對飛航業者提供飛航資料分析研究之流程 
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3. 4 跑道入侵案例探討 

論文發表者：Dennis Grossi, NTSB 

 

NTSB Dennis 提出的跑道入侵案例為 2004 年 8 月 19 日發生於洛杉機機場

Asiana Airlines Flight 204（波音 747）與 Southwest Airlines Flight 440

（波音 737）。事故發生時，Asiana 204 班機準備近場著陸時，發現 24L 跑道端

的 Southwest 400 班機正滑入跑道，因而放棄著陸採重飛避讓。 

事故發生時，塔台的場面雷達（AMASS）有紀錄到 AMASS 之警告聲響，及兩

機與塔台管制員間的通話。此一動畫中的波音 747 飛航軌跡使用航管雷達資料，

波音 737 之地面滑行軌跡是由飛航參數的加速度資料積分後獲得，如圖 6 所示。

飛航資料解讀過程中，因 Southwest 的 FOQA 資料解讀委託 Flightscape 公司，

所以事故發生後 NTSB 從 Flightscape 取得解讀資料庫 737 FFD，洛杉機機場精

密地型，衛星影像，及飛機模型，進而提升解讀及動畫製作的效率。 

圖 6 波音 737 與 747 於洛杉機機場發生跑道入侵飛航事故動畫 

Dennis 結論時指出，因為飛航事故調查單位，飛機製造商若使用相同的解

讀系統，則可以大幅提升調查效率，並減少因解讀系統不同產生的爭議及準確度

等問題。實際的例子，包括：Flash AIR 2004.01 於埃及外海失事；及上述跑道
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入侵事件。 

 

3. 5 機場障礙物圖資之發展 

論文發表者：John Synnott, IATA 

 

國際航空運輸協會(International Air Transportation Association，IATA)

發展的機場障礙物（Airport and Obstacle Database ， AODB）已有 12 年了，

該成果已成功整合於美加地區 FAA 的場面安全監控中，且 Flightviz 的機場障礙

物模組也有許多美加地區的航空業者用於與 FOQA 資料整合。目前，IATA 發展的

機場障礙物有新的計劃稱為 SkyVu。SkyVu 為 IATA 與美國衛星影像公司（Space 

Imaging）合作開發四種與機場障礙物有關圖資1（如圖 7）： 

 Cat.1 – Imaging 

 提供機場地帶 10x10 公里的 IKONOS 衛星影像 1 公尺解析度（彩

色及多波段）， 

 作為 FOQA 資料之飛航軌跡與機場場面圖套合分析， 

 作為 MANPD 分析應用（與恐怖攻擊預防有關） 

 作為航機於場面活動發生不符合操作程序時調查用途，  

 Cat. 2 - Digital Terrain and Obstacle Models 
 根據衛星影像立體像對，製作機場場面模型，包括：地型，人工

及自然的障礙物模型， 

 這些數值模型也包含了機場邊界，人工及自然的障礙物模型的高

度，航路，航機起降程序圖(SID，STAR2)等。 

 Cat. 3 - Airport Mapping Databases 
 根據 Digital Terrain and Obstacle Models 製作之機場場面移

動電子地圖， 

 避免跑道入侵（RUNWAY INCURSION）應用， 

 適合於 EFB, Aerodrome Mapping and Vis-Sim 應用， 

 規格：全球高解析度機場數位地圖，DO-272 格式，可以作 3D 檢

視，支援各式 GIS 軟體（ARCINFO，Microstation，AutoCad, 

Mapinfo），  

 Airport Mapping Images and models include: Runway 

centerline, Taxiway centerline, Runway shoulder , Taxiway 

shoulder , Exit lines , Hold lines ,Stopway ,Clearway, 

                                                 
1 Constructed to DO-272 and DO-276 standards 
2 Standard Instrument Departure (SID). For landing these paths are called Standard 

Terminal Arrival (STAR). 
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Deicing areas, Parking stand (all), Helipad, Helipad FATO, 

TOLF, Helipad threshold, Significant bodies of water. 

 Cat. 4 - Flight Simulation Visual Database 
 整合上述三種成果- imagery, terrain model, airport map， 

 應用於新型飛行模擬器之視覺系統，及提供既有飛行模擬器之地

型資料庫更新， 

 發展低價位的飛行訓練裝備（fixed training device，FTD) 

 考慮與 Flightscape 的 Insight 產品整合， 

 提供政府部門之飛航事故調查，FOQA 視覺化動畫模擬，IAT 簽約

用戶之飛航資料分析（FDA）等應用。 

圖 7 IATA 研發之 SkyVu 軟體圖層比較 

 

3.6 Insight Animation 於地面載具事故之應用 

論文發表者：Michael Hill, ATSB 

 

澳洲運安會（ATSB）屬於 Multi-Model 運輸安全委員會，載具紀錄器實驗

事有 4人，3人負責飛航紀錄器，1人（Michael Hill）負責火車及輪船紀錄器。

ATSB 已有多次經驗將火車及輪船紀錄器之解讀資料，以 Insight Animation 作

動畫並提給委員會作參考（詳圖 8/9）。 

ATSB 的論文也指出，他們也開始應用 3D SCANNER 作事故現場的地形模型，
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並將其結果轉入 Insight Animation。不過，他們遭遇若干技術困難。由於本會

於華航 611 調查中對 3D SCANNER 有良好的工作經驗，因此提供 ATSB 一些解決方

案。 
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圖 8火車紀錄器飛航動畫（上圖為兩輛火車鐵軌之管控，下圖為儀表及燈號）
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圖 9 輪船紀錄器飛航動畫（右下圖雷達航跡 JPEG FORMAT，15 秒計一張） 

 

3.7 Inisght 之未來發展 

研討會最後，Flightscape 公司說明了未來優先發展的工作項目，計有十

項。其中，前四項為本會多年來建議執行，且自行持續研發的項目。列表說明如

下： 

1. 整合地形建模及視覺化編輯工具（Global Mapper Vs. SkyVu and AODB）； 

2. 支援 OPENFLIGHT 三維模型格式； 

3. 支援地形資料庫動態載入及切割功能（Terrain database paging）； 

4. 自動化機場產生模組； 

5. 強化與整合吉普森航圖； 

6. 支援多語言文件說明功能； 

7. 進一步整合及同步處理動畫，繪圖，表列； 

8. 持續改善資料庫完整性（飛機模型，儀表，ffd 資料庫） 

9. 研發自動化資料產生引擎（automatic data generation、ADG）及特定飛機

及資料組的定義模組（definition sets of A/C and data sets for 

insight/analysis） 

10. 改善 Insight/Animation 
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3.8 參訪 TSB 工程部實驗室 

一行約 15 人花了 3小時參觀 TSB 工程部實驗室，與會人員無不對 TSB 工程

部感到佩服。TSB 的結構金相實驗室各式的分析儀器均屬國際一流等級，包括：

顯微鏡，電子顯微鏡，掃描電子顯微鏡、Ｘ射線能譜分析儀、光學金相顯微鏡、

顯微硬度計，紅外光譜分析儀等設備。此外，也有油料分析實驗儀器，MOA 多元

素分析儀、水分測定儀、運動粘度測定儀等一系列先進的油料分析設備，可以提

供滑油和液壓油中含量、雜質、水分、酸值、粘度、微生物等測試服務。參觀過

程中，TSB結構金相實驗室解說了幾項金屬疲勞(fatigue)的案例，圖10為 ATR42 

發動機旋槳因金屬疲勞後造後斷裂切面。 

TSB 工程部新上任的 TED GIVINS 主管極力整頓工程部之紀錄器及載具性能

小組，目前共有 6人，1人為負責火車紀錄器，另 1人負責飛航性能，其餘 4人

專業為飛航紀錄器。TED 指出，全世界的調查實驗室中只有英國 AAIB 保有解讀

金屬鋼絲紀錄器（WIRE RECORDER）的裝備，如圖 11。 

TSB 工程部尚有一工程技術發展組，專門從事現場物證鑑定及還原等研發

工作，例如：火燒後及泡水之文件處理，文件是否被竄改及還原，以事故現場空

照圖製作 3D model 等(圖 12)；；以 3D MAX 發展動畫模擬系統，從是「IF – THEN 

sequence」研究(圖 13)。 
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圖 10 ATR42 發動機旋槳因金屬疲勞造後斷裂切面 

 

圖 11 金屬鋼絲紀錄器 
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圖 12 火車事故現場空照圖製作 3D model 

 

圖 13 3D MAX 動畫模擬火車與卡車相撞 
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四、結論 

本次「參加 RAPS 使用者研討會」，行程圓滿且收穫豐富，提出四項心得： 

I. 參訪加拿大運輸安全委員會最大的收獲，經過與他們的調查人員私下交流及

討論後，獲得一些飛機於溼滑道面下衝出跑道調查案的内部及飛機製造商之

分析報告（因涉智慧財產權，將另案於會內提報）。 

 

II. 飛航解讀分析與動畫系統（RAPS）原屬於各政府航機失事機關所用，直至

2005 年共有 21 個政府機關，4家飛機製造廠，加拿大航管，2 家私人公司，

與 15 家航空公司加入會員。 

 

III.2005 年 RAPS 使用者研討會約有 130 餘人參加，共有 30 篇論文。調查機關

與飛機製造商對 Insight 解讀及分析之需求一致，對飛航事故調查之效率將

可大幅提升。 

 

IV. 本會調查實驗室之研發項目，與其它同業類似 

 研討會中，澳洲提出 3D Scanner 之建模應用，本會於 2003 年 ISASI 會議

發表之殘骸三維軟體重建系統，三維測繪技術於民航領域之應用研究均屬

類似研發領域（發表於 2004 年航太學術研討會，2005 年民航季刊）。 

 研討會中，IATA 提出 SkyVu 的機場障礙物圖資成果。其實，本會實驗室多

年來致力整合衛星影像及地形，航路，航道，發展了 3D GIS 應用於飛航

事故調查領域，提出 AI-GIS Layer 作法。雖然，規模雖小但其成果已可

自由運用與 Insight animation 之整合，實領先 IATA 及 Flightscape 之

研發進度。（相關論文發表於發表於 2004 年智慧型運輸系統學術研討會，

2004 年航太學術研討會中） 

 為了更有效整合 Insight animation 之地形精密度，Flightscape 資深工

程師 Bob Hoyle 透露他們内部正在研究如何將免費的精密衛星影像

（Quickbird, Landsat），及全球地形(NASA SRTM data)轉入 Insight 

animation 之中。私底下，也將本會實驗室近半年未花任何費用的研發結

果傳授 Flightscape。該結果已使印尼委託的調查，及 Flightscape 感到

驕傲。 

 

職提出五點建議如下： 

I. 未來派員參加研討會，盡量以發表論文與交換心得方式進行。藉以持續提升

本會國際聲譽，並分享調查的學習心得（Lessons Learned）與飛安建議

（Safety Recommendations）。 
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II. 基於持續擴展本會之飛航紀錄器解讀與分析能力，應逐年推薦本會年輕飛航

紀錄器工程師參加 Flightscape 舉辦的訓練課程。並添購一套 Insight 

Analysis, Insight proview 以分散工作負擔。 

 

III.我國調查實驗室已臻全球五大實驗室（美加法澳），本會應致力於推動亞太

地區飛航事故調查及飛安研發之合作及分享。積極整合進行中的調查技術相

關研究計畫，並爭取更多的經費來推動未來之持續研發需求。 

 

IV. 積極參與歐美國家正在研討的相關飛航安全研發議題，如：桌上型飛航模擬

器研發，下一代飛航參數資料庫之專家會議，派員參加現代化飛航紀錄器解

讀及分析訓練（加拿大國科會 NRC 提議，SMITH 航太主辦）。 

 

V. 為提升本會於結構及航空材料領域之專業調查能力，建議未來編列預算派員

至加拿大運輸安全委員會工程部受訓。 
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附錄 

附錄一 IATA 與 Flihtscape 的 FDA 服務內容 

附錄二 Insight 1.5 版 軟體更新功能列示
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附錄一 IATA 與 Flihtscape 的 FDA 服務內容 

IATA LAUNCHES INTERNATIONAL WEB BASED FLIGHT DATA ANALYSIS SERVICE - Signs 

multi-year agreement with Flightscape Inc. 

April 28, 2005 - As part of its continuing investment in safety, the 

International Air Transport Association (IATA) has signed an agreement 

with Flightscape Inc. to launch a Flight Data Analysis (FDA) service. This 

new service enables carriers to meet the International Civil Aviation 

Organization (ICAO) directive that calls for the incorporation of an FDA 

programme into airlines existing accident prevention programmes.  

This service is part of IATA  Safety Strategy to improve industry safety 

while reducing IATA members costs of operation and enhancing operational 

efficiency,?/i> said Guenther Matschnigg, Senior Vice President, Safety, 

Operations and Infrastructure with IATA.  

The FDA service will improve safety margins by highlighting non-standard 

circumstances as well as generating significant savings by leveraging a 

pool of industry experts and premier Flight Data Analysis solutions. The 

value of FDA will be further enhanced by IATA  unique position to share 

lessons learned across the airline community to increase global industry 

safety levels.  

The airline retains the intimate control and ultimate responsibility for 

their FDA programme. The service brings together a comprehensive suite 

of tools and expertise to unlock the value from airlines’s flight data. 

This saves airlines from having to recruit internal flight data expertise 

and associated systems by providing direct access to the very best 

analysts and methodologies available today,?/i> said Matschnigg.  

The IATA FDA Service will be powered by Flightscape, recognized in the 

industry for leading edge flight data analysis tools and expertise. 

Flightscape currently operates a successful service for several airlines, 

which will serve as the platform for IATA to enhance its safety data and 

analysis capabilities in support of its airlines. The new relationship 

recognizes that many of the processes used in accident investigation are 

equally applicable to a proactive FDA programme,. said Mike Poole, 

Managing Partner of Flightscape.  
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FDA is the newest addition to IATA  existing proactive safety tools, such 

as the Safety Report, the Safety Trend Evaluation, Analysis & Data 

Exchange System (STEADES) and the IATA Operational Safety Audit (IOSA) 

programme.  

IATA Safety Data Management and Analysis products are founded on trust 

and dialogue with the airlines, spanning 40 years in accident analysis 

and prevention, and including the only global safety incident database, 

said Matschnigg. air Transport is the safest mode of mass transportation. 

2004 was our safest year ever and we are committed to make it even safer. 

IATA has long recognized that companies with strong safety cultures are 

also leaders in operational efficiency. An FDA programme is the epitome 

of the synergy between safety and operational improvements. Good safety 

management is good management, and it’s  essential.  

IATA leads, represents and serves the airline industry. Its 265 member 

airlines comprise 94% of scheduled international air traffic.  

Flightscape, based in Ottawa, Canada, is a flight safety company that 

provides expertise in flight data playback, analysis and flight sciences. 

Flightscape develops software tools that enable the effective study and 

understanding of recorded flight data to improve safety, maintenance and 

flight operations. 
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附錄二 Insight 1.5版 軟體更新功能列示 

 

FlightScape 2005年5月推出新版的INSIGHT軟體 ver 1.5，其中存在於舊版的

問題已有大幅改進，茲列示說明如下： 

Insight Analysis-GENERAL 

 A Memory tab has been added to the Tools->Options Dialog to allow caching 

of Frame Data. Caching Frame Data into memory could significantly 

increase the performance of Insight Analysis when Frame Data is accessed 

over a network. 用來提升巨大飛航資料處理，飛航動畫內地型及衛星影

像的Rending 效能。 

 The processing speed for loading large amounts of frame data has been 

significantly improved. 

 Automatic Data Generation has been added to the Tools menu.適合於飛航

資料批次處理用 

 Function Editor has been added to the Tools menu.需先裝Borland C+ 

Complier ， x:\Program Files\Flightscape\Compiler 。 x:\Program 

Files\Flightscape\Insight Analysis\functions，為C原始碼置放路

徑。 

 The application now notifies the user of the license expiration 30 days 

prior to the expiry date. 

 The last opened project automatically gets reopened from the registry on 

application start up. 

 File Selection Dialog behavior has been improved. 

 The Site directory now contains a functions folder. i.e. 

x:\flightscape\projects\2005\B737400_ADAM_NTSC\functions 

 Site directories created in RAPS are now recognized as valid Site 

directories. 

 The reset button on dialogs that contain color widgets now resets the color 

on the Color Preview Box. 

 If a File Dialog's initial directory doesn't exist, the dialog defaults 

to a folder one level up, if that location doesn’t exist then it sets 

the initial location to Windows “My Documents” folder. 

 Insight Analysis handles importing a project by double clicking on an RPX 

file. 

 The file history list under the File menu displays a hint window when 

hovering over the file name that shows the entire path of the selected 

file. 
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 The Frame Data Selection Dialog no longer produces assertion failure after 

selecting a different FFD file for the project. 

 The Frame Data Selection Dialog remembers the previous search when it is 

reopened within the same project. The search is cleared when switching 

to a new project, FFD file, or Recovery directory. 

 The Project Import File Dialog now retains the last visited folder location 

while the application is running. 

 An already open Text Properties Dialog now properly gets updated when a 

different  

 Loading multiple DC_COMBINED parameters at once now works correctly. 

 The %U, %L and %B formats can now be used without having to specify 

additional formatting options.  For example, %U can be used instead of 

having to specify %U(%H:%M:%S). 

  

 

 

Insight Analysis-Data Analysis 

 

 Workspace files with more than 100,000 observations are displayed on 
multiple pages. The whole data set can be navigated using a slider to 

select which portion of the data to view. 

 When editing values in Data Analysis pressing the Return key will allow 
the next value to be edited. 

 When loading a Workspace file from frame data for the first time, on 
the “Workspace from Frame” dialog the “Start Time” and “End Time” 

fields are pre-filled with the time range that is stored in the Master 

Index. 

 The text on the View->History Dialog no longer contains invalid 
characters. 

 On the Math function dialogs the time range fields initially are 
pre-filled with the time range for the entire Workspace file. 

 Viewing the History of a newly created Workspace file no longer causes 
an access violation. 

 Entering invalid input into the Calculator no longer causes an access 
violation. 

 Access violations no longer occur when using “Constant” values in 

Speed Conversions. 
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Insight Analysis-Data Exchange 

 Data Exchange has been enhanced to allow for the selection of a 
parameter such as GMT or Frame Counter to detect missing time, rather 

than using only the subframe number. 

 Unpacked binary data import has been enhanced to support variable 
header lengths. 

 CSV Import now copies the format specified in the configuration file 
into the output Workspace file. 

 If the Time parameter exists in the CSV file it is given precedence 
over the rest of the time parameters (Hours, Minutes, Seconds) when 

creating the time column for the output Workspace file. 

 The Data Import File Dialog now remembers the path of the last selected 
data file after application restart. 

 Thales EQAR data can now be imported. 

 Removed the Honeywell QAR option from the frame input data type since 
it is the same as the Unpacked Binary format. 

 Unpacked Binary Frame files with .dat extensions now import correctly. 

 When importing a CSV file, X value special formats specified in the 
configuration file or the CSV file are now used in the created Workspace 

files as the time formats. 

 The Workspace file output has been moved from the Physical to the 
Logical Frame output selection. 

 The title on the ASCII Bitstream and the Honeywell DLU options screen 
now gets updated properly. 

 

 

 

Insight Analysis-FFD Editor 

 The invalid warning message is no longer produced after creating a new 
parameter and trying to add subframe and word after adding a conversion. 

 A CSV export option has been added for the parameter list display. 

 Binary representations of sync codes are now correct. 

 Access violations no longer occur when testing a conversion. 
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 If the display format field is left blank when adding or modifying a 
parameter, a default format is now assigned. 

 Assertion errors are no longer produced after creating multiple 
parameter duplicates. 

 Printing in the FFD Editor now uses the standard Windows print dialog, 
and prints all the parameter information displayed. 

 When printing selected parameters the last parameter selected now gets 
printed as well. 

 The dc_COMBINED function now handles signed parameters, zero and one 
overlapping bits. 

 Subframe, Word, Bit locations and Number of Bits can now be selected 
in the Sort and Display fields options. 

 Sort and Display field settings are now saved to the registry. 

 Deleting multiple parameters no longer fails if the parameter’s name 

is displayed in the second column. 

 The special conversions C file (dc_convert_special.c) in the FFD Editor 
compiles correctly in all cases. 

 Delete, Duplicate, Merge and Save options as well as searching options 
(such as Search/Restore/Sort/Display Fields) are disabled when the 

parameter property dialog is open. 

 Searching for a specific group of parameters and deleting a parameter 
from the displayed list no longer causes an access violation. 

 When a new parameter or duplicate parameter is added - it is now set 
to Not Compiled by default. 

 Attempting to import a Boeing CSV file after changing the Column Heading 
no longer causes an access violation. 

 Exiting with the Cancel option on the Save Prompt dialog no longer 
causes an access violation. 

 Deleting the contents of the dc_convert_special.c file no longer causes 
an access violation. 

 When saving a FFD template, the calibration directory is now saved in 
the template. 

 Adding Superframe parameters no longer produces an assertion error. 

 Entering zero as a sync code now works correctly. 
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Insight Analysis-Flight Data Scan 

 If a value of 0 is entered for the "Minimum Event Duration", the scan 
will detect instantaneous events.  Events of only 1 sample, such as 

a peak vertical acceleration, will be detected. 

 

 

 

Insight Analysis-Master Index 

 An error message is displayed if the FFD file is not set or doesn’t 

exist for the current project. 

 An error message is now displayed when trying to add a Frame file with 
no subframes. 

 

 

 

 

Insight Analysis-Named Ranges 

 When closing the Named Range dialog by pressing the Cancel button, a 
warning message is displayed if the named range list is modified. 

 Start and End match item display color has been fixed. 

 Named Range field now gets cleared if either the Start or End Time has 
been changed. 

 

 

 

 

Insight Analysis-Plotting 

 If any object’s color would be the same as the background color when 

added to the plot, the color will be set to the “inverted color” 

instead. 

 The Time Label keeps the relative position to the grid when the grid 
is moved, and no longer gets repositioned when the page size is changed. 

 Time based lines now pan with the rest of the plot. 

 The panning rate has been improved for large time ranges. 

 Copy style from text to parameter and line to parameter now copies all 
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the required attributes correctly. 

 PDF files can now be saved using File->Save As and selecting the Adobe 
PDF file type. 

 When changing a parameter name in the Object Manager with more than 
one parameter, the parameter order is no longer switched. 

 Creating a new plot with the settings from the default Plot file now 
works correctly in all cases. 

 The Time value on the Playback Control bar now gets updated while 
panning. 

 System fonts are no longer anti-aliased for better RAPS compatibility. 

 Panning stops if it reaches the minimum or maximum range of all 
available data. 

 When plotting a frame parameter that is not “User Validated” in the 

FFD file, it is now correctly displayed as a grey dotted line. 

 The “Invert Colors” feature in Plotting has been improved to use hue, 

saturation and luminance (HSL) instead of RGB. 

 Printing problems have been resolved. 

 The border that was being drawn around the plot has been removed. 

 A "Floating point division by zero” error no longer occurs when setting 

the number of Major or Minor Ticks in the Grid Properties to 0. 

 Thickness of Parameter Resolution now works correctly. 

 When “Clip To Grid” is turned off for Time Based Text, it works 

properly on both sides of the plot 

 Movement of the mouse cursor with Time Based text and lines is now 
synchronized. 

 Grid lines, Axis lines and Ticks are no longer anti-aliased. 
 

 Workspace files can be added to a plot even if they are contained in 
a subdirectory of the “eng” directory. 

 Switching a converted frame parameter to raw sets the format to %.0f 
instead of clearing the display format field. 

 When text is added to a plot by importing it from a CSV file, it uses 
the text style that is defined in the default Plot file. 

 The default bounding box margins for text have been changed from 0 to 
5. 

 New text and lines have the same default static position mode. 
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 A new line now has a default thickness of 2 and has an arrow at one 
end. 

 Rotating Time based Text using the mouse now rotates in the correct 
direction. 

 When the Group folder name has been changed, Text and Line object Group 
names are properly updated as well. 

 When multi-selecting objects in the Object Manager the pop-up menu is 
no longer available. 

 Delete now works for multiple folders in the Object Manager. 

 Moving objects from one folder to another in the Object Manager now 
works correctly. Text and Lines can be properly moved from folder to 

folder and copying the styles works correctly. 

 Insight Analysis no longer crashes when switching between plots that 
are read-only and not read-only. 

 When importing RAPS plots the line thickness conversions are now 
handled properly. 

 Saving a parameter line thickness as default now produces correct line 
thicknesses. 

 Wrap limit now works correctly. 
 

 

 

 

Insight Analysis-Tabular 

 Drag and drop now works even after enabling Alternate X. 

 Column width is retained after drag and drop. 

 Column resizing issues are fixed. 

 Added support for exporting to the CDF format. 

 On the Time Properties Dialog, “Step Size” now uses the FDAU 

information in the FFD file to increase or decrease the time. 

 Named Range changes now only take effect when the Apply or OK button 
is clicked. 

 When Alternate X is enabled, the context menu (Properties, Delete) is 
not shifted. 

 Parameter titles that span more than three lines get displayed 

properly. 
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 An hour glass cursor has been added to indicate when data is being 
loaded. 

 The pop-up menu is no longer available for an empty Tabular file. 

 Deleting the last parameter in a newly created Tabular file no longer 
causes an access violation. 

 

 

 

 

Insight Animation-General 

 A Graphics tab has been added to the Tools->Options Dialog to allow 
significant performance increases and rendering quality (Smooth Edges, 

Texture Sharpening, Cache Models and Fast Render optimizations). 

 Performance when rendering complicated instrument models has been 
improved. 

 The application displays a warning if video card drivers are needed. 

 Restriction on the window aspect ratio has been removed to allow 
animations to fill the entire screen or multiple screens. 

 Added audio support for ISV files. 

 The Frame rate indicator (FPS) has been removed from the Status Dialog 
and has been added to the Status bar on the application window. 

 ISV files can now be opened from read-only locations such as CDs. 

 ISV files can be opened even when the user does not have administrator 
access privileges. 

 The application now notifies the user of the license expiration 30 days 
prior to the expiry date. 

 If Insight Animation is closed by clicking File->Exit, the recently 
opened file history is now properly updated. 

 The file history list under the File menu displays a hint window when 
hovering over the file name that shows the entire path of the selected 

file. 

 The processing speed for loading large amounts of frame data has been 
significantly improved. 

 If multiple models reference the same texture, the textures are not 
loaded multiple times, improving performance. 

 The last opened project automatically gets reopened from the registry 
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on application start up. 

 File Selection Dialog behavior has been improved. 

 The Site directory now contains a functions folder. 

 Site directories created in RAPS are now recognized as valid Site 
directories. 

 An access permission error message is no longer displayed on start up 
if the Site directory's model folder is empty. 

 When loading an animation template the name of the template file in 
the Title bar of the application window now gets updated. 

 The Properties Dialog for newly added models now correctly displays 
the model name in the window border. 

 When saving an animation as an ISV file, the ISA file remains the active 
file. 

 Open project doesn’t cause the application to crash if a previously 

opened project's folder location doesn't exist anymore. 

 Opening a template file no longer causes any exceptions or odd 
behaviour. 

 The Project Import File Dialog now retains the last visited folder 
location while the application is running. 

 If a File Dialog's initial directory doesn't exist, the dialog defaults 
to a folder one level up, if that location doesn’t exist then it sets 

the initial location to Windows “My Documents” folder. 

 Insight Animation handles importing a project by double clicking on 
an RPX file. 

 The same File menu options are available for an ISV file opened from 
within a valid project as for an ISA file. 

 The Frame Data Selection Dialog remembers the previous search when it 
is reopened within the same project. The search is cleared when 

switching to a new project, FFD file, or Recovery directory. 

 The Object Manager no longer causes an access violation if file reading 
fails. 

 The “Import” option has been removed from the Object Manager Data 

Folder and 

 Data Exchange has been added to the Tools menu. 

 The Terrain Import Dialog has been improved to allow selection of a 
region from a World Map image. 
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 In the Terrain Import Dialog all Latitude and Longitude values can be 
entered to 6decimal places of accuracy. 

 The Shadow Visible Toggle functionality on the Font Properties Dialog 
has been fixed. 

 Fonts set to italic are no longer displayed as bold. 

 The reset button on dialogs that contain color widgets now resets the 
color on the Color Preview Box. 

 On the Playback Control bar 0 is now accepted as a valid start time 
value. 

 The Data Set, Path and Parameter context menus no longer contain a 
“Reread” option. A “Refresh” button has been added to the main Edit 

menu and Toolbar for consistency with other Insight applications. 

 ISV files now correctly save all image textures. 

 The Apply button on the Contrail Properties Dialog now functions 
correctly. 

 When loading an animation with a smaller time range than a previously 
loaded animation, the current time is no longer set to the end of the 

time range. 

 The last line of a CSV file imported into Subtitles now imports 
correctly. 

 Adding longer than 80 character length lines to the Subtitle Text no 
longer causes an access violation. 

 Access violations no longer occur when a new animation is created while 
one of the Object Manager’s dialogs is still open. 

 Surface Configuration file color scales now work correctly. 

 Surface Configuration file “Use vertex colors” setting is now 

correctly saved. 

 Rotation now works correctly for Y and Z axes in the Object properties. 

 When a Scene Object is connected to a path, translations and rotations 
are now applied in addition to the path X/Y/Z translations and 

roll/pitch/heading rotations.  In previous versions the Scene Object 

translations and rotations were ignored in this case. 

 If the name of the parameter is being changed to an invalid name in 
the Object 

 Manager a warning message is displayed and the name remains the same 
as before. 
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 In the Sparks Dialog the Y value of the length and position entry fields 
are no longer inverted. 

 The default camera zoom has been changed to 30. 
 

 

 

Insight Animation-Automatic Data Generation (ADG) 

 All ADG functions now update the parameter descriptor in any output 
Workspace files to match the ADG Workspace file name. 

 If no takeoff or landing is detected, ADG sets the flight time to the 
beginning of the path. 

 ADG functions are no longer run if the data set time range has been 
changed. 

 ADG now allows Frame parameters to be used directly in addition to 
Workspace files. 

 ADG_Correct_Alt_Near_Ground() now handles different Landing and 

Take-Off pressure altitudes. 

 Improved the vertical alignment on runways. 

 ADG_Fix_Bad_Data() now handles Min/Max and Data Spikes simultaneously. 

 ADG no longer crashes when using the path creation functions with an 
empty 

 Workspace file (one that contains header information, but no data) as 
input. 

 

 

 

 

Insight Animation-Data Exchange 

 Data Exchange has been enhanced to allow for the selection of a 
parameter such as GMT or Frame Counter to detect missing time, rather 

than using only the subframe number. 

 Unpacked binary data import has been enhanced to support variable 
header lengths. 

 CSV Import now copies the format specified in the configuration file 
into the output Workspace file. 

 If the Time parameter exists in the CSV file it is given precedence 
over the rest of the time parameters (Hours, Minutes, Seconds) when 
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creating the time column for the output Workspace file. 

 During CSV import if the Sort keyword is specified in the Configuration 
file and an empty Workspace file is created, Insight Animation no longer 

tries to sort the empty file and in doing so causing the import to fail. 

 The Data Import File Dialog now remembers the path of the last selected 
data file after application restart. 

 Thales EQAR data can now be imported. 

 Removed the Honeywell QAR option from the frame input data type since 
it is the same as the Unpacked Binary format. 

 Unpacked Binary Frame files with .dat extensions now import correctly. 

 When importing a CSV file, X value special formats specified in the 
configuration file or the CSV file are now used in the created Workspace 

files as the time formats. 

 The Workspace file output has been moved from the Physical to the 
Logical Frame output selection. 

 The title on the ASCII Bitstream and the Honeywell DLU options screen 
now gets updated properly. 

 

 

 

Insight Animation-Model Import 

 The Model Import Dialog always displays the selected model properties. 

 Models are no longer created in the wrong directory. 

 An option has been added to allow normals defined in the OBJ file to 
be used. 

 Changed the default value for smoothing from 0.5 to 0.3. 

 A normals calculation bug has been fixed. 

 Units selection now works correctly. 

 Proper column spacing has been added on the Surfaces tab. 

 Performance has been improved significantly so Model Import no longer 
appears to hang on the import of certain OBJ files. 

 

 

 

 

Insight Animation-New from Fleet Wizard 
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 The Data Import now uses the parameter (PRM) file name specified in 
the Fleet file. 

 The Start Time now correctly displays the minimum data range if it is 
other than 0. 

 The Time widget is now properly updated, no longer causing an error 
while producing Workspace files. 

 The New from Fleet Wizard no longer pops up after opening a file by 
double-clicking on it. 

 If the New from Fleet Wizard is used to create an animation with 
previously imported data, the “Finish” button is now enabled without 

data import, using the Workspace files that were previously created. 

 The Data Exchange Wizard is now used if defaults for the specified data 
for import are unknown. 

 The overall time range is now determined from the project including 
Frame Data and Workspace files. 

 When choosing a Start time greater than zero the current time in the 
animation is set correctly. 

 The FFD file specified in the Fleet file is now used instead of 
auto-selecting one from the project. 

 

 

 

 

Insight Animation-Path Creation 

 Path Create functions have been updated to allow the selection of Frame 
Data as input parameters. 

 Latitude/Longitude flight paths can now be created. 

 If an error occurs while filling out the details in the Path Create 
Dialogs, the main dialog no longer closes after the error message is 

displayed. 

 The Path creation dialogs now retain their previous settings, and only 
get reinitialized if the Recovery directory for the specific Data Set 

that the Path is part of is changed. 

 The Path output parameter location now defaults to the “recovery/eng” 

folder instead of the “recovery” folder. 
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Insight Recovery 

 Insight Recovery is a new application being released with Insight 1.5. 

 Insight Recovery is an ARINC flight data editor that allows interactive 
editing of frame data and viewing of the converted engineering units 

on the fly. 

 With Insight Recovery it is possible to access frame data by “logical” 

time or load physical bitstream data by blocks.  

 Waveform data digitized from tape based FDR’s can also be viewed. 

Insight Recovery records all changes made to a file for future 

reference. 

 

 

Insight ProView 

 A Graphics tab has been added to the Tools->Options Dialog to allow 
significant performance increases and rendering quality (Smooth Edges, 

Texture Sharpening, Cache Models and Fast Render optimizations). 

 Performance when rendering complicated instrument models has been 
improved. 

 The application displays a warning if video card drivers are needed. 

 Restriction on the window aspect ratio has been removed to allow 
animations to fill the entire screen or multiple screens. 

 Added audio support for ISV files. 

 The Frame rate indicator (FPS) has been added to the Status bar on the 
application window. 

 ISV files can now be opened from read-only locations such as CDs. 

 ISV files can be opened even when the user does not have administrator 
access privileges. 

 The application now notifies the user of the license expiration 30 days 
prior to the expiry date. 

 The Tool bar at the top of the screen no longer crops off the top portion 
of the animation. 

 Insight ProView maintains its own File History list. 



 

ASC-TRM-05-07-001 42

 If Insight ProView is closed by clicking File->Exit, the recently 
opened file history is now properly updated. 

 The file history list under the File menu displays a hint window when 
hovering over the file name that shows the entire path of the selected 

file. 

 

 

 

 


